I'm retarded, please help me

I want to install these 2 mods (picrelated). How do I do this

  1. 6 days ago
    Anonymous

    click > download > drag to game data folder

  2. 6 days ago
    Anonymous

    You have to download Mod Organizer 2, and there is a tutorial there when you start it

  3. 6 days ago
    Anonymous

    Go and take a look at an app called Wabbajack, you're retarded so you wanna stick with modlists, if you're not familiar with Skyrim modding it's too late to get in the game now and you need premium on nexus.

    • 6 days ago
      Anonymous

      >now and you need premium on nexus
      Really? It's been a few years since I last loaded Skyrim full of mods and I can't see myself ever bothering to update them (or the launcher, I still haven't done the anniversary update). But now you have to pay to dl mods?

      • 6 days ago
        Anonymous

        >But now you have to pay to dl mods?
        nah they're still free but your dl speed is cappped
        shame they recently updated their servers' security, i had a very handy ftp

        • 6 days ago
          Anonymous

          >nah they're still free but your dl speed is cappped
          Jokes on them internet speeds are garbage here.

          • 6 days ago
            Anonymous

            Yeah I got the premium before it became subscription only but the difference really isn't that huge for me? what's the cap exactly? I generally hover between 1 and 5 MB

      • 6 days ago
        Anonymous

        You don't need to pay but modlists are the new thing and if you're not paying you have to wait an eternity for those modlists to download. Also there's partitions between modlists that support AE version and the GOTY version.

        • 6 days ago
          Anonymous

          Like a modpack? I know compatibility can be an issue with some mods, but nothing I've installed has caused issues before. Downloading a curated list does sound pretty neat for someone starting from scratch.

          • 6 days ago
            Anonymous

            just don't go for the coomer shit on wabbajack, otherwise your charracter is going to get raped by wolves and you don't want that, trust me.

            • 6 days ago
              Anonymous

              But I do want that.

    • 6 days ago
      Anonymous

      >need premium on nexus

      no you dont.

  4. 6 days ago
    Anonymous

    Don't, arthmoors patch is full of shit that isn't bugfixes, although i'm not sure what the recommended alternative is right now

    • 6 days ago
      Anonymous

      There's still quite a bit of good mods requiring it for dependencies. Just install it and the mod that revert those shitty changes.

  5. 6 days ago
    Anonymous

    Just use Vortex, it's Nexus's retard proof mod manager and it should work fine for those two

  6. 6 days ago
    Anonymous

    Use Vortex my friend! Alternatively, look up a video on how to do it! Its super easy once you get the hang of it! Some others do no like Vortex and prefer other Mod Managers! Modding can be a blessing once you understand how to do it, and troubleshoot!

  7. 6 days ago
    sage

    >Make an account
    >download Vortex
    >log in to nexus account on Vortex
    >on Nexus webpage, click "DOWNLOAD WITH VORTEX"

    Only run Skyrim from Vortex from then on and all will work fine, 100% of the time.

  8. 6 days ago
    Anonymous

    >installing the unofficial patch
    ISHIGYDIGGY

Your email address will not be published. Required fields are marked *